aboutsummaryrefslogtreecommitdiffstats
path: root/noetic-llama/src/ollamawrapper/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'noetic-llama/src/ollamawrapper/CMakeLists.txt')
-rw-r--r--noetic-llama/src/ollamawrapper/CMakeLists.txt26
1 files changed, 19 insertions, 7 deletions
diff --git a/noetic-llama/src/ollamawrapper/CMakeLists.txt b/noetic-llama/src/ollamawrapper/CMakeLists.txt
index c94424b..4533887 100644
--- a/noetic-llama/src/ollamawrapper/CMakeLists.txt
+++ b/noetic-llama/src/ollamawrapper/CMakeLists.txt
@@ -55,10 +55,10 @@ find_package(catkin REQUIRED COMPONENTS
# )
## Generate services in the 'srv' folder
-add_service_files(
- FILES
- OllamaCall.srv
-)
+#add_service_files(
+# FILES
+# OllamaCall.srv
+#)
## Generate actions in the 'action' folder
# add_action_files(
@@ -104,9 +104,9 @@ generate_messages(
## DEPENDS: system dependencies of this project that dependent projects also need
catkin_package(
# INCLUDE_DIRS include
-# LIBRARIES ollamawrapper
-# CATKIN_DEPENDS roscpp rospy std_msgs
-# DEPENDS system_lib
+ LIBRARIES ollamawrapper
+ CATKIN_DEPENDS roscpp rospy std_msgs message_runtime
+ DEPENDS system_lib
)
###########
@@ -164,6 +164,18 @@ catkin_install_python(PROGRAMS
DESTINATION ${CATKIN_PACKAGE_BIN_DESTINATION}
)
+install(
+ DIRECTORY src/capabilities/
+ DESTINATION ${CATKIN_PACKAGE_BIN_DESTINATION}/capabilities
+)
+
+install(FILES
+ src/Modelfile.jinja2
+ src/ollamafunctiongrammar.ppeg
+ src/parser.py
+ DESTINATION ${CATKIN_PACKAGE_BIN_DESTINATION}
+)
+
## Mark executables for installation
## See http://docs.ros.org/melodic/api/catkin/html/howto/format1/building_executables.html
# install(TARGETS ${PROJECT_NAME}_node