aboutsummaryrefslogtreecommitdiffstats
path: root/anime-face-detector/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'anime-face-detector/setup.py')
-rw-r--r--anime-face-detector/setup.py42
1 files changed, 0 insertions, 42 deletions
diff --git a/anime-face-detector/setup.py b/anime-face-detector/setup.py
deleted file mode 100644
index dc634f5..0000000
--- a/anime-face-detector/setup.py
+++ /dev/null
@@ -1,42 +0,0 @@
-# --------------------------------------------------------
-# Fast R-CNN
-# Copyright (c) 2015 Microsoft
-# Licensed under The MIT License [see LICENSE for details]
-# Written by Ross Girshick
-# --------------------------------------------------------
-
-import os
-from os.path import join as pjoin
-import numpy as np
-from distutils.core import setup
-from distutils.extension import Extension
-from Cython.Distutils import build_ext
-import sys
-
-
-# Obtain the numpy include directory. This logic works across numpy versions.
-try:
- numpy_include = np.get_include()
-except AttributeError:
- numpy_include = np.get_numpy_include()
-
-# run the customize_compiler
-class custom_build_ext(build_ext):
- def build_extensions(self):
- build_ext.build_extensions(self)
-
-ext_modules = [
- Extension(
- "nms.cpu_nms",
- ["nms/cpu_nms.pyx"],
- extra_compile_args=["-Wno-cpp", "-Wno-unused-function"] if sys.platform == 'linux' else [],
- include_dirs = [numpy_include]
- )
-]
-
-setup(
- name='tf_faster_rcnn',
- ext_modules=ext_modules,
- # inject our custom trigger
- cmdclass={'build_ext': custom_build_ext},
-)